Rating 4.6
Number of voters 2.1M
Compatibility Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Author url https://www.roblox.com/
Author Roblox Corporation
Content Rating 12+
Languages English, French, German, Indonesian, Italian, Japanese, Korean, Portuguese, Russian, Simplified Chinese, Spanish, Thai, Traditional Chinese, Turkish, Vietnamese