Rating 2.5
Number of voters 306322
Compatibility Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.
Publication date 2017-03-20 0:00:00
Author Snap, Inc.
Content Rating Rated 12+ for the following:
Languages English, Arabic, Danish, Dutch, Finnish, French, German, Greek, Indonesian, Italian, Japanese, Korean, Norwegian Bokmål, Polish, Portuguese, Romanian, Russian, Simplified Chinese, Spanish, Swedish, Traditional Chinese, Turkish
Purchases a:0:{}